Bike won't start FI light steady

Done a good mod that people might want to copy? Post it here - full step-by-step instructions and pix.

FAQs can go in here too
aerosolfarmer
Newbie
 
Posts: 2
Joined: Fri Mar 16, 2012 2:15 am

Bike won't start FI light steady

Postby aerosolfarmer » Tue Apr 24, 2012 12:52 am

While riding on my second tank of gas my bike fi light flashed then the bike died. It acted like the battery was dead. the gauge ect all went blank. Got back to the shop and found the battery quite lively. I cleaned everything up now the FI light is on steady and the bike does not start. the fuel pump isn''''t pressurizing or anything.

like I said its on the second tank after putting on a yoshi exhaust. Motohooligan airbox flies sas removed. has O2 sensors eliminated not with tuneecu but with the plugs with wire resistors (bought triumph ones).

User avatar
AGRO!
Master of the twisties
 
Posts: 2644
Joined: Mon Oct 04, 2010 8:15 am
Location: Australia Northern NSW

Re: Bike won't start FI light steady

Postby AGRO! » Tue Apr 24, 2012 1:43 am

Sounds to me like the fuel pump has crapped itself. When you turn the key to on can you hear the fuel pump?
If not it could be dead.
Also have you ever cleaned and lubed the big grey plug on right hand side up under the fuel tank? This plug can cause trouble also.

aerosolfarmer
Newbie
 
Posts: 2
Joined: Fri Mar 16, 2012 2:15 am

Re: Bike won't start FI light steady

Postby aerosolfarmer » Tue Apr 24, 2012 2:02 am

No I'll try to lube em. going to the shop now.


Return to How to do it!

Who is online

Users browsing this forum: No registered users and 2 guests