Tachometer Issues

problems . solutions . product reviews . tips
Porkchop Express
Two wheeled terror
 
Posts: 230
Joined: Fri Sep 30, 2011 3:05 am

Tachometer Issues

Postby Porkchop Express » Sat Jun 29, 2013 7:06 pm

Hi Everyone,
For the last couple of months I've been having problems with my tachometer. I can tell the bike is idling perfectly but there are times the tach says I'm at zero rpm's when I know it's really idling at about 1,500 to 1,600. When it's reading low like this the tach needle will never go about 4,000 rpm although I might actually be revving it near redline. Today the opposite happened and it was showing it was idling at 4,000 rpm's and revving to redline even when I know the bike was actually at no more than 5,000 rpm's. This is my second instrument cluster on the SD as the first one was replaced due to a leak which caused it to stop working altogether. The replacement cluster is the 2010 version that seems pretty good at sealing out water but this tachometer issue is really annoying. I tried searching the site for similar problems forum members were reporting but I only found threads about SD's that were truly idling at the wrong rpm (in other words the tach was working fine but the engine wasn't idling properly). With mine it's the opposite, the engine is idling/performing perfectly but the tach is giving me completely bogus readings. Has any one else had an experience like this and if so what did you do to resolve it? I really don't want to have to buy a 3rd entire instrument cluster because it's obvious these things are junk and I hate to spend money on something I know will break again in a year or so.

Thanks in advance for your help.

Jpatterson
Minimoto racer
 
Posts: 6
Joined: Sat Nov 04, 2017 11:50 pm

Re: Tachometer Issues

Postby Jpatterson » Mon Nov 06, 2017 6:04 pm

Hello. Did you ever find a fix for this?

gotswap
Two wheeled terror
 
Posts: 175
Joined: Sun Jun 12, 2011 1:12 am
Location: Colorado Springs

Re: Tachometer Issues

Postby gotswap » Mon Nov 06, 2017 8:03 pm

I wouldn't expect a response, they have not been on for over a year
2007 SD, Sold
2015 SDR, loving every minute!

User avatar
Sarasota_Steve
moderator
 
Posts: 1202
Joined: Wed Feb 12, 2014 9:14 pm
Location: Sarasota, FL, USA

Re: Tachometer Issues

Postby Sarasota_Steve » Tue Nov 07, 2017 2:51 pm

I had that happen to me during a track day. The speedo and rpm went nuts. Sometimes showing 4K rpm while idling. Ended up being a loose connection inside the nose mask. Right side as you are sitting on the bike.
Ride Hard,
------------------
Sarasota_Steve
08 990 SDR


Return to Technical - Dr F's Words of Wisdom

Who is online

Users browsing this forum: No registered users and 6 guests