Bike turns over but wont start after fitting oxford grips

problems . solutions . product reviews . tips
Bigpumpkin
Minimoto racer
 
Posts: 8
Joined: Wed Jul 26, 2017 12:19 am

Bike turns over but wont start after fitting oxford grips

Postby Bigpumpkin » Sat Sep 02, 2017 1:49 pm

Still trying to get my '07 back in sound running order. I went for a 150 mile ride two days ago and the beast was running perfectly. Just humming along like she should. Yesterday I installed some oxford heated grips. An hour later I went to start the bike and engine just keeps turning over and wouldn't catch. I've gone through the fuses, disconnected and reconnected the BGC and disconnected the Oxford leads from the battery. The battery is at 100% power and I've started checking the rats nest around the battery. Still nothing. Any thoughts? really frustrating. Finally have a nice day and I want to ride!

User avatar
No. 47
Master of the twisties
 
Posts: 2823
Joined: Sat Jan 10, 2009 5:14 pm
Location: London and Kent

Re: Bike turns over but wont start after fitting oxford grip

Postby No. 47 » Sat Sep 02, 2017 2:21 pm

Headlamp unit up or down?
'08 ex-Battle race KTM Superduke 990 R No.47
'08 OE KTM Superduke 990 R
'01 Ducati 996S

User avatar
bic_bicknell
moderator
 
Posts: 3797
Joined: Sun Sep 13, 2009 7:11 am
Location: Bristol

Re: Bike turns over but wont start after fitting oxford grip

Postby bic_bicknell » Sat Sep 02, 2017 5:54 pm

I was out today riding in 85 degree summer, overheating in leathers and full face helmet. As I sat at some long wait traffic lights and the sweat trickled down my back to soak my T shirt even more I thought to myself, "I really must get home and fit some heated grips".

I'd just take the grips off mate and get your bike running like it was! ;)
Past: Honda CB125J, Honda TL125, 1963 Triumph Tiger 90, Yamaha RD250, Kawasaki KH250, Kawasaki 400 S3, Kawasaki KH400, Kawasaki Z400J, Suzuki GS750, Suzuki GS1000, Ducati SS900 Superlight, KTM LC4 Supermoto, Honda VFR 800i, KTM Superduke '07.

User avatar
jmann
moderator
 
Posts: 1741
Joined: Sun Mar 22, 2009 2:28 am
Location: Sunny Adelaide, Australia

Re: Bike turns over but wont start after fitting oxford grip

Postby jmann » Tue Sep 05, 2017 10:37 am

Listen to Comrade No.47

DribbleDuke
Master of the twisties
 
Posts: 3540
Joined: Wed Nov 14, 2007 3:53 am
Location: Los Alamos, Ca

Re: Bike turns over but wont start after fitting oxford grip

Postby DribbleDuke » Tue Sep 05, 2017 5:01 pm

Bigpumpkin wrote:Still trying to get my '07 back in sound running order. I went for a 150 mile ride two days ago and the beast was running perfectly. Just humming along like she should. Yesterday I installed some oxford heated grips. An hour later I went to start the bike and engine just keeps turning over and wouldn't catch. I've gone through the fuses, disconnected and reconnected the BGC and disconnected the Oxford leads from the battery. The battery is at 100% power and I've started checking the rats nest around the battery. Still nothing. Any thoughts? really frustrating. Finally have a nice day and I want to ride!

Clutch override switch, check tab on clutch lever.
I'm BLUE


Return to Technical - Dr F's Words of Wisdom

Who is online

Users browsing this forum: No registered users and 1 guest

cron