Bike running rough

problems . solutions . product reviews . tips
User avatar
TimR
Two wheeled terror
 
Posts: 322
Joined: Fri Apr 11, 2008 11:36 am
Location: Stockport, UK

Bike running rough

Postby TimR » Mon Apr 16, 2018 5:05 pm

I just bit the bullet and got my 990 serviced, including valve check. The bike seemed fine afterwards and at the weekend I headed into North Wales for a ride.

Prior to this (2 months ago), I’d had problems with reg/rec which were resolved by fitting a MOSFET unit, but I don’t think this problem is electrics-related.

After about 100 miles (and probably 200 in total since the service) the bike started to behave strangely. I noticed revs were high and hunting in neutral at a standstill – up to about 1800 rpm. Then at around 3000rpm in the first few gears, on a neutral/light throttle the bike started to hesitate and run rough. This then spread up to about 5000rpm. The next time I stopped, the revs rose in neutral to 3000rpm. I got home OK, the bike didn’t stall and when turned off, it restarted without any trouble. There are no warning lights showing.

Yesterday I took the tank off to check there were no trapped pipes or cables – all seemed OK, the MH airbox was properly seated/secured and the rubber boots looked OK. Of course, when I put it back together and took it for a quick test ride, it didn’t show the problems. I guess it needs to be ridden for a longer time/distance to show the problem again.

I phoned the bike place that serviced it and they’ve said to bring it back in to have a look, which I am planning to do later this week. The mechanic said he thought it sounded throttle body related.

I have searched but can’t find anything to point me in a particular direction. Anyone experienced these symptoms?

User avatar
No. 47
Master of the twisties
 
Posts: 2944
Joined: Sat Jan 10, 2009 5:14 pm
Location: London and Kent

Re: Bike running rough

Postby No. 47 » Mon Apr 16, 2018 6:06 pm

Could be many things but in absence of error codes, first check TB rubbers again viewtopic.php?f=5&t=12511&p=335070&hilit=Rubbers#p335070
'08 ex-Battle race KTM Superduke 990 R No.47
'08 OE KTM Superduke 990 R
'01 Ducati 996S

Bazzaz
Minimoto racer
 
Posts: 11
Joined: Thu Jun 12, 2014 10:03 am
Location: The Hague, Netherlands

Re: Bike running rough

Postby Bazzaz » Tue Apr 17, 2018 10:04 pm

The hesitating and the rising idle (to 3ktpm) i've had as well, on my bike it was the TPS... mine was broken so I replaced it and set it to the correct values and the problem was solved.

User avatar
TimR
Two wheeled terror
 
Posts: 322
Joined: Fri Apr 11, 2008 11:36 am
Location: Stockport, UK

Re: Bike running rough

Postby TimR » Wed Apr 18, 2018 9:18 am

Thanks for the replies.
I'm taking it over to the bike shop tomorrow - hopefully they will find the problem and fix - even better if they acknowledge that it was something that was set correctly during the service - unlikely I know, but I can dream!


Return to Technical - Dr F's Words of Wisdom

Who is online

Users browsing this forum: No registered users and 3 guests