Another warranty issue

Questions or Comments on Dealers, Stores, Warranty, Insurance, recalls and common faults
jonnyrotton
Two wheeled terror
 
Posts: 321
Joined: Thu Jun 19, 2014 8:49 am
Location: Litchfield Park, Arizona

Another warranty issue

Postby jonnyrotton » Fri Dec 12, 2014 12:21 am

Well, after the 4th tank in a row of gas, my fuel sending unit is doing the same thing reading erraticly. When working properly, it would drop one bar every 30 miles or so. Lately my gage will drop one bar between 48-60 miles and stay one bar down through 90 miles and will then drop 3 bars down and back up sporadically(over a short time period not quick) to one bar down, then to 4 bars down then to 3, etc. It does however seem to be still fairly accurate with only 3 bars left and down. I called the dealer today to let them know and was told they just need to call ktm to let them know whats going on and they would get back to me. So it hasn't been set in stone, but should be taken care of under warranty. Unless that part is also on backorder like everything seems to be for the 1290, then I'm just going to wait till it comes in and have them do my 2nd clutch cover(with the bearings) replacement and the fuel pump unit together. The clutch cover gasket had been on backorder since the end of september and came in around 4-5 days ago.
Last edited by jonnyrotton on Fri Dec 12, 2014 6:21 am, edited 1 time in total.

REDTALE2000
Two wheeled terror
 
Posts: 190
Joined: Thu Apr 03, 2014 3:08 am
Location: Ojai, CA

Re: Another warranty issue

Postby REDTALE2000 » Fri Dec 12, 2014 2:04 am

Y'know JR, I could pretty easily imagine that to be "normal" behavior. If you're doing pretty much anything besides straight line droning, there's gonna be a lot of turmoil in that tank especially when partially filled. So, unless you've experienced different behavior from this guage when driving the same route and at the same enthusiasm level, you may not get much satisfaction from replacing things. I've never seen really ideal bevavior from any bike fuel guages but they generally do the job of letting you know when to start worrying. I still use the trip meter for my cut-it-close adventures...
2014 1290 85K miles

User avatar
ktmguy
Site Admin
 
Posts: 6100
Joined: Fri Oct 30, 2009 3:23 am
Location: Townsville Qld, Aussie.

Re: Another warranty issue

Postby ktmguy » Fri Dec 12, 2014 5:14 am

Don't we have a tread under 1290 warranty issues, I'm sure I saw it somewhere.... must have misplaced it...

Anyway, the system works as follows. For it to work you need two things distance and fuel level. Hence when resetting the trips it doesn't work for a while till you covered some distance.
So it could be one of 3 things. Software, fuel level sensor or the trip meter playing up.
On my bike it worked really accurate till they updated the software, now it seems a bit more erratic but not like you describe.
If you don't do anything stupid when young, you have nothing to smile about when old!


Image

jonnyrotton
Two wheeled terror
 
Posts: 321
Joined: Thu Jun 19, 2014 8:49 am
Location: Litchfield Park, Arizona

Re: Another warranty issue

Postby jonnyrotton » Fri Dec 12, 2014 5:31 am

Guy, first off this is under "warranty tread ”. The issues that are happing are happening on the straight boring, droning routes as well as curvier routes. These are some of the routes I've taken many times on my super duke and the gauge has not acted in this way before the last 4 fill ups. Plus I always set my trip and go by it, but since it's under warranty and should be somewhat accurate (which it has until recently) I want everything to work properly. I'm hoping this is not typical KTM quality/reliability. 6 months left of warranty, if things don't calm down, I might be a ktm owner for another 6 months. But if they do pretty much get sorted out, I wouldn't mind holding on to this bike for a good while.

User avatar
ktmguy
Site Admin
 
Posts: 6100
Joined: Fri Oct 30, 2009 3:23 am
Location: Townsville Qld, Aussie.

Re: Another warranty issue

Postby ktmguy » Fri Dec 12, 2014 6:04 am

Ahem my mistake, I was talking about the fuel range. (might be the heat here at the moment... :roll: )
The fuel gauge should be like you describe in your post, drop bar by bar.
So probably the tank unit might be faulty. Is the Software ever been updated and what version you have in the dash?
If it is been updated always make sure the mechanic sets all the parameters to 1290 SDR as the software is the same for 1290 SDR, ADV1190 and ADV 1050.
If you don't do anything stupid when young, you have nothing to smile about when old!


Image

jonnyrotton
Two wheeled terror
 
Posts: 321
Joined: Thu Jun 19, 2014 8:49 am
Location: Litchfield Park, Arizona

Re: Another warranty issue

Postby jonnyrotton » Fri Dec 12, 2014 6:19 am

I'm not sure what version I have. Its never been updated since I bought it June 11th. And since nothing has changed that may have caused the fluctuation, I believe the sending unit is failing. I see the sending unit is all one unit with the fuel pump, so looks like the whole fuel pump will have to be exchanged just to fix the sending unit.


Return to Stores, Dealers, Warranty, Insurance and Safety Issues

Who is online

Users browsing this forum: Majestic-12 [Bot] and 1 guest