Gone through 4 radiators with two SDR 1290s...

For all 1290 related problems . solutions . product reviews . tips
Roja
Two wheeled terror
 
Posts: 104
Joined: Sat Oct 31, 2015 2:30 pm

Gone through 4 radiators with two SDR 1290s...

Postby Roja » Tue Jul 11, 2017 8:39 am

Having two 2015 SDR's, in the last two years, we're on our third radiator on one of them and just cracked the second radiator on the other bike. NONE of the radiators have been hit. All four of them have leaked in the same place - just below the upper left mount (left, if you're sitting on the bike) - just below the 'L' mount.

Both bikes have Evotech rad guards and have a little more than 50,000 km on them. Both bikes also have improved front suspension, which should somewhat reduce stress caused by road vibrations.

I am in contact with KTM Austria, and will be getting another radiator, but I was surprised to see that there seems to only be one other person to have had the same (or similar) problem on here.

SUPER DUKE #1
Two wheeled terror
 
Posts: 328
Joined: Thu Mar 10, 2011 2:39 am

Re: Gone through 4 radiators with two SDR 1290s...

Postby SUPER DUKE #1 » Thu Jul 13, 2017 6:13 pm

All four of them have leaked in the same place - just below the upper left mount (left, if you're sitting on the bike) - just below the 'L' mount.


If it were my bike, I would remove the bolt at that left side "L" bracket and leave it out. At the most I might put a plastic (zip) tie strap as just a little tension but for sure I wouldn't secure the new radiator at that point. Sure seems like vibration at that area of the "L" mount is the cause of the failures IMO. Is that "L" mount under abnormal tension? Maybe the radiator frame mount is miss-welded and not aligned or the rubber damper ring in not damping??? I would just take that mounting bolt and bracket out of the equation by leaving the bolt out.......don't think the radiator will even miss it with the others in place.

SD#1

davegixer
Minimoto racer
 
Posts: 7
Joined: Tue Jun 07, 2011 5:55 pm
Location: Oxfordshire UK

Re: Gone through 4 radiators with two SDR 1290s...

Postby davegixer » Sat Jul 15, 2017 9:05 am

SUPER DUKE #1 wrote:
All four of them have leaked in the same place - just below the upper left mount (left, if you're sitting on the bike) - just below the 'L' mount.


If it were my bike, I would remove the bolt at that left side "L" bracket and leave it out. At the most I might put a plastic (zip) tie strap as just a little tension but for sure I wouldn't secure the new radiator at that point. Sure seems like vibration at that area of the "L" mount is the cause of the failures IMO. Is that "L" mount under abnormal tension? Maybe the radiator frame mount is miss-welded and not aligned or the rubber damper ring in not damping??? I would just take that mounting bolt and bracket out of the equation by leaving the bolt out.......don't think the radiator will even miss it with the others in place.

SD#1


Really good advice that, definitely sounds like an issue with tension on the mount.

xtremewlr
Minimoto racer
 
Posts: 90
Joined: Wed Nov 26, 2014 6:37 pm
Location: Lemon Grove, California

Re: Gone through 4 radiators with two SDR 1290s...

Postby xtremewlr » Sun Aug 27, 2017 4:07 pm

SUPER DUKE #1 wrote:
All four of them have leaked in the same place - just below the upper left mount (left, if you're sitting on the bike) - just below the 'L' mount.


If it were my bike, I would remove the bolt at that left side "L" bracket and leave it out. At the most I might put a plastic (zip) tie strap as just a little tension but for sure I wouldn't secure the new radiator at that point. Sure seems like vibration at that area of the "L" mount is the cause of the failures IMO. Is that "L" mount under abnormal tension? Maybe the radiator frame mount is miss-welded and not aligned or the rubber damper ring in not damping??? I would just take that mounting bolt and bracket out of the equation by leaving the bolt out.......don't think the radiator will even miss it with the others in place.

SD#1


Have another look at that mount. You will see that the bolt doesn't provide any "tension" to the mount, it only prevents the radiator from moving off the mount. Photo for reference. Not my bike though.

Image

Swifty
Minimoto racer
 
Posts: 8
Joined: Fri May 01, 2009 10:31 am
Location: Victoria, Australia

Re: Gone through 4 radiators with two SDR 1290s...

Postby Swifty » Wed Nov 15, 2017 10:20 am

I have a 2014 model with 60,000 km on the clock. Had a new radiator supplied under warranty at about 30k for the same fault. Now have a leak from the right side. Attempting to seal before having to buy another at A$900. Have been told importer may offer a "deal" if resealing fails.

Roja
Two wheeled terror
 
Posts: 104
Joined: Sat Oct 31, 2015 2:30 pm

Re: Gone through 4 radiators with two SDR 1290s...

Postby Roja » Fri Aug 03, 2018 9:14 am

Reason has been found...

The tank mounts twisted = tank vibration = torsión communicated through lateral wings = radiator cracks at top mounting points.

Solution. Take tank off and make sure the mounts are in the properly aligned (maybe ever wrap in tape to make sure they don’t twist).

robertkehl
Stunt rider
 
Posts: 524
Joined: Sun Aug 10, 2008 7:30 pm
Location: Livermore, Ca.

Re: Gone through 4 radiators with two SDR 1290s...

Postby robertkehl » Fri Sep 21, 2018 10:50 pm

I know this is a old thread, but my radiator cracked in the same area just last month on my 2014. It had less than 8k on the bike. Dealer replaced it for $800 American dollars. No warranty, A typical for KTM of America. Dealer said this was the third one they had done this year. One thing they all had in common, they all had guards on them. Dealer told me that KTM owns its own radiator factory for what it's worth.
The 1290 is what the 990 was suppose to be.


I ride Ktm Motorcycles, yep :-)

Roja
Two wheeled terror
 
Posts: 104
Joined: Sat Oct 31, 2015 2:30 pm

Re: Gone through 4 radiators with two SDR 1290s...

Postby Roja » Sun Oct 14, 2018 8:24 am

We know all this info.
KTM built radiators for Bmw.

The issue has been found.

Any radiators that crack at the mount are due to the same fault. Nothing to do with a Rad Guard.

As I’ve said, I’ve gone through eight (8; VIII) radiators. With guard, without, and tried every variable.

The solution / cause remains the same.


Return to Technical [SDR 1290]

Who is online

Users browsing this forum: No registered users and 6 guests